Animation Tutorial for Flyers

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Animation Tutorial for Flyers

Postby minilogoguy18 » Mon Mar 27, 2006 12:57 pm

Ok i finished writing this tut but since its so large youll have to download it to save ALOT of time waiting for the page to load. If you have any questions post in this thread and NOT PM me, admins can also stickie this if they want. Remember this tutorial is intended for advanced users only so most things required to do this are explained in the XSI help files.

Vehicle_Setup_Tutorial.zip
or
View it Online!

Missing Jedi Admin
Posts: 3277
Joined: Fri Nov 12, 2004 2:54 pm

RE: Animation Tutorial for Flyers

Postby Leviathan » Mon Mar 27, 2006 1:24 pm

Off-topic : I guess transforming this thread into a "Sticky" will make things much easier for GameToast members who would wish to put their hands down on this precious resource... :wink:

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

RE: Animation Tutorial for Flyers

Postby minilogoguy18 » Mon Mar 27, 2006 4:04 pm

yes this is a more simplistic way of animating where as the more complicated way was the way that the jedi fighter was set up and that same way that no one could figure out how to make work. this way is alot faster and easier but it enveloping meshes eats up game memory and when you use that up youll see things like effects not showing when something blows up and things of that sort.

Brigadier General
User avatar
Posts: 629
Joined: Thu Jun 23, 2005 6:06 am

RE: Animation Tutorial for Flyers

Postby Jawa_Killer » Mon Mar 27, 2006 4:12 pm

lol.........if a simple animation look like that how does a walk animation of an atap look like LOL^^

Lord-Bandu

RE: Animation Tutorial for Flyers

Postby Lord-Bandu » Mon Mar 27, 2006 5:07 pm

Good tutorial. Pretty simple .

If it wasnt for that pesky Jedifighter!..

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

RE: Animation Tutorial for Flyers

Postby minilogoguy18 » Mon Mar 27, 2006 9:21 pm

well the jedi fighter is the correct way to animate flyers, this is just the easy way.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Mon Jul 10, 2006 5:51 pm

ok, i need help.
i get the animation to work and it work ingame but i have problems with the animated parts.
here are 2 pics

http://img169.imageshack.us/img169/1407/14yn1.jpg

http://img169.imageshack.us/img169/4420/22ef.jpg

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Postby minilogoguy18 » Mon Jul 10, 2006 8:27 pm

i cant tell what your problems are from an in-game shot, i need to see some stuff in XSI. one thing i can see though is that a part is outta place and that only happens if your model is segmented into seperate peices when it needs to be all 1 mesh.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Tue Jul 11, 2006 4:45 am


Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Postby minilogoguy18 » Tue Jul 11, 2006 9:39 am

ok, the heirarchy looks ok, did you set up the keyframes right? basepose should be just the skeleton and any animated hardpoints from frames 0 - 1 and take off is the ship actually animating and its frame 1- whatever, the 2 sequences have to share the frame thats between them. also are you sure all the paths are set up right when munging the zaabin and zafbin files cause if they arent then the game wont read them cause you cant call them in the odf so thier path has to be a certain way. look at some of the shipped models to see more on how that stuff should be and how you should name your folders. also try reading through the tut again but very carefully, i made it while actually working on the Virago so i didnt leave anything out.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Tue Jul 11, 2006 11:16 am

ok,
in my C:\BF2_ModTools\data_TES\Animations folder i have a clean.bat,munge.bat and a munge_subdir.bat and create a folder Vehicle.
in the vehicle folder is the munge_animation.bat and the cis_fly_sheathiped folder.
in the cis_fly_sheathiped folder is a munge.bat.
i edit the bat files, like you did in the tutorial.
in the in the cis_fly_sheathiped folder folder i save basepose.msh and takeoff.msh
when i munge the msh i found in my new side folder in munged a
cis_fly_sheathipede.anims
cis_fly_sheathipede.zaabin
and a
cis_fly_sheathipede.zafbin file.

after this i munge the map.

the keyframe are there,i made a keyframe at 0 and 1 for dummyroot, without this keyframes, xsi crash when i try to export the basepose.msh or takeoff.msh

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Postby minilogoguy18 » Tue Jul 11, 2006 11:51 am

all the bones must be keyed at 0 and 1, not just dummyroot. when you export you have to set the start and end times for basepose at 0 and 1 and for takeoff from 1 to whatever in the time slider and for the actual model file itself you export everything but dont check export animations in the dialogue box.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Tue Jul 11, 2006 1:52 pm

i give all bones a keyframe at 0 and 1, but the same problem ingame.
i test only the model without animations and it work, only with the animation it wont work.

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Postby minilogoguy18 » Tue Jul 11, 2006 2:06 pm

well 1 last thing i can think of is that your not collapsing the construction history or freezing the mesh, expand the polygon mesh node in the explorer for the mesh and let me see it, also select the model and let me see the transform panel on the right to see if its zeroed out.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Tue Jul 11, 2006 2:45 pm

here it is:
http://img45.imageshack.us/img45/2475/50es.jpg


edit:
ok, i tryed 1000 different things and wont work, i tryed another vehicle and i had the same problem.
i hope i can send you the model, so you can take a look and find the problem.
this would be great

thanks
dragonum

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Postby minilogoguy18 » Tue Jul 11, 2006 7:05 pm

well your problem is the most important thing and its even mentioned in the documentation, the transforms nor the geometry are frozen, this will give you errors in ANY game. what you need to do is click on the model then click on the "freeze" button on the bottom of the right panel and if your monitor is at a low resolution (like most peoples for some dumb reason) and you cant see the freeze button you can click on the edit bar on the right panel NOT the edit at the top menu and go edit>operator>freeze selected. this will freeze the construction history and youll lose the envelopes but theyre easily redone. now select the mesh and do transform>freeze all transforms on the right panel and then do another freeze selected. now reassign the vertex weights and then export the model again and it should work. for ANYTHING animated you have to have the model and the transforms frozen or else it wont work, the transform panel should have all 1's for scaling and all 0's for rotation/translation and in the polygon mesh node there shouldnt be anything but *envelope operator. also another helpful thing, after exporting do an undo cause the exporter feezes the transforms giving you that *center operator which can mess you up.

2nd Lieutenant
User avatar
Posts: 405
Joined: Tue Nov 16, 2004 4:08 pm

Postby Dragonum » Wed Jul 12, 2006 4:25 am

now it work.
thanks minilogoguy :D


dragonum

2nd Lieutenant
User avatar
Posts: 396
Joined: Tue Jan 16, 2007 4:22 pm
Location: The left side of the moon
Projects :: Space to Ground [reworking]
Games I'm Playing :: Different Games
xbox live or psn: No gamertag set

Re: Animation Tutorial for Flyers

Postby Redline » Sun May 10, 2009 9:03 am

Hello I've a problem with the exporting of my model.
Well the problem is that xsi is crashing everytime when I'm trying to export it.
Here are two screens about the exporting errors.
What does this mean? I really don't know a lot about animations, but I think I have to freeze them.
Okay pls, have a look at these two screens and tell me what I'm doing wrong.
Thx in advance minilogoguy.
Ps:I followed your tutorial.

Hidden/Spoiler:
ImageImage

Master Bounty Hunter
User avatar
Posts: 1525
Joined: Wed Nov 09, 2005 11:12 pm

Re: Animation Tutorial for Flyers

Postby minilogoguy18 » Sun May 10, 2009 10:50 am

The error is pretty self explanatory, there are vertexes that have no weight properties. Even if it is a section of the model that is not animated it still needs to be weighed to a bone, that is why I made the 'master' bone which is bone_root for the ships body. Go over the model and find whatever vertexes that have no weights and rig them to the parent bone.

2nd Lieutenant
User avatar
Posts: 396
Joined: Tue Jan 16, 2007 4:22 pm
Location: The left side of the moon
Projects :: Space to Ground [reworking]
Games I'm Playing :: Different Games
xbox live or psn: No gamertag set

Re: Animation Tutorial for Flyers

Postby Redline » Mon May 11, 2009 12:20 pm

minilogoguy18 wrote:The error is pretty self explanatory, there are vertexes that have no weight properties. Even if it is a section of the model that is not animated it still needs to be weighed to a bone, that is why I made the 'master' bone which is bone_root for the ships body. Go over the model and find whatever vertexes that have no weights and rig them to the parent bone.


Hmm... that's weird all vertexes have weight or maybe i don't see them.
I dunno what I should do now. >_<

Next

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 1 guest