[SOLVED] [ZETools] Assigning texture to imported MSH

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Private First Class
User avatar
Posts: 80
Joined: Thu Sep 01, 2016 3:41 pm
Projects :: Tatooine - Jundland Wastes
Games I'm Playing :: SWBF2
xbox live or psn: No gamertag set

[SOLVED] [ZETools] Assigning texture to imported MSH

Postby mrcluster » Sat Jul 27, 2019 12:35 pm

As I have a copy of XSI Modtool 7.5 on hand due to past endeavours, I've decided I'll try to use ZETools with it to make my first kitbash. I will admit I'm woefully inexperienced with XSI - and I'm currently running into my first problem. I'm currently trying to import the EP3 Clone Pilot, and all's well on that front - the .msh file loads in. However, his textures, on the other hand, do not - he's just left as a bunch of black lines showing the polygons he's comprised of. I've read online that the ZETools "Manage Materials" option is the way to go for assigning textures to objects, but I've had no luck. There seem to be four already-loaded materials when the Clone Pilot is imported: "Scene_Material", "Scene_Material0 - ZE | 4", "Material40 - ZE | 2", and "Material51 - ZE | 1". Assigning these materials the texture I want, then assigning them to the model (or doing either of these individually) doesn't seem to do anything, and still leaves the pilot as a bunch of polygons. I, strangely, cannot find any tutorial on how to do this properly, so could someone lead me down the right path?

EDIT: Oh, I've found the issue out - it displays, by default, the wireframe of the model, and you must set it to "textured" or "textured decal" to see it.

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 2 guests